dato search shopping envelope Pinterest youtube LinkedIn Facebook Twitter instagram search

WordPress 5.1 Site Health

Den nyeste version 5.1 af WordPress kommer med en ny feature kaldet Site Health, som viser en notifikation i kontrolpanelet, hvis serveren som WordPress kører på bruger en forældet version af PHP-programmeringssproget.

WordPress kan køre med PHP version 5.2.4 eller nyere, men de ældste af disse PHP-versioner bliver ikke længere vedligeholdt, så der er sikkerhedsmæssige risici forbundet med at bruge dem. De versioner af PHP der bliver aktivt vedligeholdt pt. er 7.2 og 7.3. Version 7.1 er ved at blive faset ud, men får stadig sikkerhedsopdateringer til og med november 2019.

WordPress Site Health advarer hvis PHP 5.5 eller ældre er i brug på serveren. Man får ikke nogen advarsel hvis serveren kører PHP 5.6, selvom denne version heller ikke længere bliver vedligeholdt (efter 1. januar 2019).

Opdatering af PHP

I nogle tilfælde kan man selv opdatere PHP, hvis hosting-udbyderen har et kontrolpanel der giver mulighed for at skifte mellem forskellige PHP-versioner. Efter at man har opdateret er det vigtigt at gå websitet igennem og tjekke at alt fungerer som det skal, da nogle ældre temaer og plugins kan give problemer med de seneste versioner af PHP. Disse problemer kan som regel løses ved at opdatere temaer og plugins til nyere versioner.

Hvis man ikke har mulighed for selv at skifte PHP-versionen, bør man kontakte udbyderen og bede dem om at opdatere til en nyere version.

I nogle tilfælde kan der være installeret software på serveren (f.eks. CloudLinux), der indholder sikkerhedsopdateringer til ældre versioner af PHP. I disse tilfælde er det ikke noget sikkerhedsmæssigt problem at bruge forældede PHP-versioner. Websitet vil dog i mange tilfælde kører hurtigere med en nyere udgave af PHP, så det er stadig en god ide at opdatere.